最終更新:2018-09-12 (水) 07:50:58 (95d)  

TensorFlow/インストール/Ubuntu はてなブックマークを見る

https://www.tensorflow.org/install/install_linux#NVIDIARequirements

Linux

TensorFlow with CPU support only.

TensorFlow with GPU support.

  • GPU drivers. CUDA 9.0 requires 384.x or higher.
  • CUDA Toolkit 9.0?.
  • cuDNN SDK? (>= 7.2).
  • CUPTI?
  • Optional:

インストール方法

virtualenv (推奨)

pip in system

Docker (nvidia-docker)

  • ホストにはCUDAのインストール不要。
    $ nvidia-docker run -it -p 8888:8888 tensorflow/tensorflow:latest-gpu

pip in Anaconda