最終更新:2016-10-12 (水) 17:10:24 (1363d)  

NDK_TOOLCHAIN_VERSION
Top / NDK_TOOLCHAIN_VERSION

Define this variable as either 4.9 or 4.8 to select a version of the GCC compiler.

  • Version 4.9 is the default for 64-bit ABIs, and 4.8 is the default for 32-bit ABIs.
  • To select a version of Clang, define this variable as clang3.4, clang3.5, or clang.
  • Specifying clang chooses the most recent version of Clang.

バージョン別

Android NDK r12b

  • Android NDK/build/core/setup-toolchain.mk?
        # We default to using GCC, which is the first item in the list.
        TARGET_TOOLCHAIN := $(firstword $(TARGET_TOOLCHAIN_LIST))
        ifdef NDK_TOOLCHAIN_VERSION
            ...
            VERSION := $(NDK_TOOLCHAIN_VERSION)
            TARGET_TOOLCHAIN := $(TARGET_TOOLCHAIN_BASE)-$(VERSION)
            $(call ndk_log,Using target toolchain '$(TARGET_TOOLCHAIN)' for '$(TARGET_ARCH_ABI)' ABI (through NDK_TOOLCHAIN_VERSION))
        else
            $(call ndk_log,Using target toolchain '$(TARGET_TOOLCHAIN)' for '$(TARGET_ARCH_ABI)' ABI)
        endif

Android NDK r13

  • Android NDK/build/core/init.mk?
    # Default to Clang.
    ifeq ($(NDK_TOOLCHAIN_VERSION),)
        NDK_TOOLCHAIN_VERSION := clang
    endif

関連