最終更新:2016-11-15 (火) 13:24:24 (1339d)  

Android/ビルド/Ubuntu 12.04
Top / Android / ビルド / Ubuntu 12.04

Ubuntu/バージョン

JDK/バージョン

Ubuntu/Java

その他

  • http://source.android.com/source/initializing.html#installing-required-packages-ubuntu-1204
    $ sudo apt-get install git gnupg flex bison gperf build-essential \
      zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \
      libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 \
      libgl1-mesa-dev g++-multilib mingw32 tofrodos \
      python-markdown libxml2-utils xsltproc zlib1g-dev:i386
    $ sudo ln -s /usr/lib/i386-linux-gnu/mesa/libGL.so.1 /usr/lib/i386-linux-gnu/libGL.so

メモ

  • 下記のエラーが出る場合 (Ubuntu 12.04.3とか?)
    The following packages have unmet dependencies:
     libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 8.0.4-0ubuntu0.5)
                            Recommends: libgl1-mesa-dri:i386 (>= 7.2)
    E: Unable to correct problems, you have held broken packages.
  • libgl1-mesa-glx:i386の代わりにlibgl1-mesa-glx-lts-quantal?:i386かlibgl1-mesa-glx-lts-raring?:i386を入れる。
    $ sudo apt-get install git gnupg flex bison gperf build-essential \
      zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \
      libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx-lts-raring:i386 \
      libgl1-mesa-dev g++-multilib mingw32 tofrodos \
      python-markdown libxml2-utils xsltproc zlib1g-dev:i386

Ubuntu 12.04.5

メモ

  • 試しにlibglapi-mesa?を先に入れたら色々パッケージが消えてログイン画面が出なくなった

Android 4.0のビルド

  • GCC 4.6だとエラーが出るっぽい。

いじったファイル

  • AOSP/build/core/combo/HOST_linux-x86.mk
  • AOSP/external/mesa3d/src/glsl/linker.cpp?
  • AOSP/external/oprofile/libpp/format_output.h?
  • AOSP/external/gtest/internal/gtest-param-util.h?
  • AOSP/external/llvm/llvm-host-build.mk?
  • AOSP/frameworks/compile/slang/Android.mk?

参照