最終更新:2016-11-15 (火) 13:53:11 (1358d)  

Android/ビルド/Ubuntu 14.04
Top / Android / ビルド / Ubuntu 14.04

https://source.android.com/source/initializing.html

Ubuntu/バージョン

Android 6.0

  • ビルドにはOpenJDK 8?が必要だけどリポジトリにない。一応Ubuntu 15.04のが使える。
  • There are no available supported OpenJDK 8? packages for Ubuntu 14.04. The Ubuntu 15.04 OpenJDK 8? packages have been used successfully with Ubuntu 14.04.
    • Newer package versions (e.g. those for 15.10, 16.04) were found not to work on 14.04 using the instructions below.

VirtualBox/Guest Additions

  • Ubuntu 14.04.2だとvirtualbox-guest-x11が入らない
  • 最新のVirtualBox付属のGuest Additionsを入れること。
    • DKMSをインストールしてからインストール
      apt-get update
      apt-get upgrade
      apt-get install dkms
      sh ./VBoxLinuxAdditions.run

環境

  • 16GBのRAM/swap
  • 100GB or more of disk space in order to build the Android tree.
  • At least 100GB of free disk space for a checkout, 150GB for a single build, and 200GB or more for multiple builds. If you employ ccache, you will need even more space.

割り当て

パッケージ

  • Java 7 (OpenJDK)
    • openjdk-7-jdk
      $ sudo apt-get install openjdk-7-jdk g++-multilib
      $ sudo apt-get install bison g++-multilib git gperf libxml2-utils make python-networkx zlib1g-dev:i386 zip

エラー

  • The following packages have unmet dependencies:
    g++-multilib : Depends: gcc-multilib (>= 4:4.8.2-1ubuntu6)
  • とか出る場合、g++-multilibを先に入れたら大丈夫だった。

repo

  • $ mkdir ~/bin
    $ PATH=~/bin:$PATH
    $ curl https://storage.googleapis.com/git-repo-downloads/repo > ~/bin/repo
    $ chmod a+x ~/bin/repo
    $ git config --global user.email "user@ubuntu"
    $ git config --global user.name "user"
    $ mkdir android-5.1.1_r
    $ repo init -u https://android.googlesource.com/platform/manifest -b android-5.1.1_r1

メモ

関連